討論區快速選單
知識庫快速選單
政府補助!學嵌入式+物聯網 網路投保旅行平安險 討論區最近新進100則主題
[ 回上頁 ] [ 討論區發言規則 ]
找不到 AjaxControlToolkit 組件
更改我的閱讀文章字型大小
作者 : 7836(cancer) 人氣指數超過10000點
[ 貼文 100 | 人氣 10753 | 評價 210 | 評價/貼文 2.1 | 送出評價 9 次 ] 
[ 給個讚 ]  [ 給個讚 ]  [ 回應本文 ]  [ 發表新文 ]  [ 回上頁 ] [ 回討論區列表 ] [ 回知識入口 ]
2009/12/21 下午 11:01:40
各位好,

請幫忙一下如何解決找不到 AjaxControlToolkit 組件的問題,情形如下。
開發電腦:筆記型電腦。
網頁電腦:公司主機。
工具:Visual Studio 2008 + AjaxControlToolkit
專案目錄:D:\FECC\
主機目錄:D:\FECC\

第一次:專案在筆電開發,測試過 OK,在主機建立目錄,設定 IIS,檔案放上主機,全部網頁都能跑。
第二次:修改過部份網頁,放上主機蓋掉同名檔案,編頁也是全部能跑。
第三次:在筆電 修改和新增一些網頁和資料夾, Visual Studio 測試全部能跑。
第四次:因為改的東西比較多,跑到主機房,停掉網站,把網站目錄裡面的所有檔案移到其他地方當做備份,再把筆電上面整個目錄裡面的檔案,複製進去,重啟網站,一打開首頁,就出現找不到 AjaxControlToolkit 組件的錯誤。
第五次:不甘心,把剛複製上去的檔案全部清空,把備份再放回來,就跟先前一樣所有網頁都能跑。

請位各位大大,是甚麼原因使得第四次的做法會失敗呢?同樣的東西本機能跑,但主機不能跑。我不可能一個個檔案比對哪些該上傳至主機,所以最有效的辦法,就是全部送上主機,這樣萬無一失,但反而出現這種奇怪的錯誤。至於 AjaxControlTookit 版本,肯定都一樣。請幫忙解決,謝謝。
作者 : 7836(cancer) 人氣指數超過10000點
[ 貼文 100 | 人氣 10753 | 評價 210 | 評價/貼文 2.1 | 送出評價 9 次 ] 
[ 給個讚 ]  [ 給個讚 ]  [ 回應本文 ]  [ 發表新文 ]  [ 回上頁 ] [ 回討論區列表 ] [ 回知識入口 ]
2009/12/22 上午 10:30:56
不好意思,找到原因了。因為我在 web.config 裡面用了 <identity impersonate ... />,帳號和密碼都是本機的,放上主機前忘記改成主機的帳號,主機自然因無此帳號而出錯,錯誤原因難找的原因是伺服器不會說是帳號不對,反而說是找不到 Ajax 組件,誤導了我的判斷方向,謝謝各位點閱,本文就算是大家以後的參考。
 板主 : 小朱
 > ADO.NET - 討論區
 - 最近熱門問答精華集
 - 全部歷史問答精華集
 - ADO.NET - 知識庫
  ■ 全站最新Post列表
  ■ 我的文章收藏
  ■ 我最愛的作者
  ■ 全站文章收藏排行榜
  ■ 全站最愛作者排行榜
  ■  月熱門主題
  ■  季熱門主題
  ■  熱門主題Top 20
  ■  本區Post排行榜
  ■  本區評價排行榜
  ■  全站專家名人榜
  ■  全站Post排行榜
  ■  全站評價排行榜
  ■  全站人氣排行榜
 請輸入關鍵字 
  開始搜尋
 
Top 10
評價排行
ADO.NET
1 小朱 1520 
2 識丁 280 
3 吳馨琳 270 
4 小台 180 
5 Snaking 140 
6 mark 140 
7 好說 120 
8 ammon 100 
9 toyboy 70 
10 再見男人 50 
ADO.NET
  專家等級 評價  
  一代宗師 10000  
  曠世奇才 5000  
  頂尖高手 3000  
  卓越專家 1500  
  優秀好手 750  
Microsoft Internet Explorer 6.0. Screen 1024x768 pixel. High Color (16 bit).
2000-2018 程式設計俱樂部 http://www.programmer-club.com.tw/
0.03125